GNU GPL with anti-aggression exception

а не пора ли задуматься над дополнением лицензий GPL/BSD
«этот продукт запрещается использовать в интересах государства и всех государственных структур а также высших должностных лиц государства, которое

1) аннексировало территории другого государства вопреки решению ООН и/или Международного суда до момента прекращения аннексии

или
2) решением генассамблеи ООН признано поддерживающим терроризм — до момента решения ООН признающего его более не поддерживающим терроризм

или
3) признано ООН совершающим преступления против человечества — до момента предания высших должностных лиц Международному суду».

👍НравитсяПонравилось0
В избранноеВ избранном0
LinkedIn
Допустимые теги: blockquote, a, pre, code, ul, ol, li, b, i, del.
Ctrl + Enter
Допустимые теги: blockquote, a, pre, code, ul, ol, li, b, i, del.
Ctrl + Enter

Таки и нормальные страны подпасть могут.

Какие ж это «нормальные» страны, если в них такое происходит?

добавил в свой проектик
github.com/...ter/license.txt
with “the anti-aggression states exception”:
* no government entities, it’s agencies do not possess any rights to use the library if
* the state wich is governed by the government:
* 1. is defined as a terrorism supporter by either UN, OSCE or NATO,
* 2. annexiated any territory of any other state(s) without UN, or OSCE or NATO approval.

Подписаться на комментарии